Why is this harder for the people who bothered to test it?

RIGHT, Windoze 10 release day! Woot, yay, and all that cobblers. Looks like the upgrade process is going fairly smoothly for most people who didn’t actually test the damn thing.

So how the hell do upgrade?

Seriously, one of the most irritating things about Windows 10 is that it installs updates when it wants to, not when you want to. I left some feedback with extra details, actually:

Auto Updates Are Dumb

They pretty much don’t give a shit. But now, it’s not upgrading me to the official public release automatically! How ironic! Maybe it’s busted because I’ve been on Build 10074 for ages since the two latest builds on the Slow ring didn’t support my network drivers, meaning I couldn’t friggin’ get on the Internet.

So, I’m basically stranded on a pre-release build of Windows 10 with no way of upgrading to secure my free copy of Win10. The only option I have is to install Windows 7 again, run the Windows 10 installer from within Win7, upgrade to secure my free Win7 -> Win10 upgrade, then boot from the Windows 10 installer, format my drive and install a fresh copy of Win10. Because I don’t trust Windows’ upgrade process for shit and always want to install new OSs from fresh. I mean, my network driver issue was probably caused by the upgrade process. 😛

It’s a bit of a faff, but pffft, no problem. Can do. On it like a car bo… what the fuck:

Media Creation Tool MAXIMUM FAIL

I got this completely professional and informative error message when I tried to use Microsoft’s official “Media Creation Tool” or whatever it’s called to get an ISO to burn to disc. A-FUCKING-MAZING.

I found this Reddit thread which shows some other people are having the same problem. A solution suggested there was to make a new Admin user and try launching the installer from there. TeamViewer took a shit on me when I switched users, but eventually I managed to log in as the new user “PhuckinWindoze”. The downloader booted OK. “Ah, sweet, that’s fixed it; it’s downloading the ISO now.” I thought. “Everything’s backed up, so when I get home tonight it’s ready to go, should have it installed no prob– WHAT THE ACTUAL FUCK”:

OH MY FUCKING GOD ARE YOU SERIOUS

You are ACTUALLY shitting me, right? Windows’ sense of humour hur hur hur but it’s NOT A JOKE, this is ACTUALLY AN ERROR. The ISO that had appeared during the download was now nowhere to be found. I tried again thinking the download was duff, but nope. Same cocking error.

Then, you know what? Through a random Google search, I found a DIFFERENT webpage on Microsoft’s site that sends you to a place where you can just download an ISO. No shitty tools or something happening. The link I originally followed to get the Media Creation Tool was one that was on the Insider site. So yeah, Microsoft made it harder for the ones who actually tested their OS for them. THANKS. A LOT.

Oh yeah, and as Microsoft just loves to add a twinge of confusion, on that site there are two English region options for the download: “English” and “English International”. I wasn’t particularly sure which one to get, and I had to confirm that the latter was actually “English UK”. So if you’re actually English/Welsh/Scottish/Northern Irish, not American, you’ll want “English International”. Because of course, “International” globally means “Not America”… 😛

Should you upgrade? Kind of an impossible question, really. I’d say “not yet”. Partially because it’s probably still got 6 quadrillion bugs, but mainly because I have no idea of the state of the release build. 😛 I’ll go first and letcha know if it’s safe later on. 😉

UPDATE!!

OH MY GOD WHAT THE HELL IS GOING ON?!

Seriously. I just tried to burn this ISO to a DVD. ImgBurn claimed that the disc I inserted was a DVD-RW.

No. It isn’t. It just isn’t.

I ejected the disc and reinserted it and it picked it up as a DVD+R. CORRECT. “WELL DONE HAVE A COOKIE. Now burn the fucking image!”

Guess what? After an excessively long 15-minute burn, the verify failed IMMEDIATELY. THEN guess what? IMGBURN THINKS IT’S A DVD-RW AGAIN!

It ISN’T a DVD-RW! It’s a cocking DVD+R! IT SAYS RIGHT HERE ON THE DISC:

2015-07-29 19.57.25

WHAT IN THE SHIIIIIIIT?!?! Seriously, this is beyond retarded. I decided to humour ImgBurn by saying “YEAAAH you GO AHEAD and ERASE that DVD+R and then CRASH cuz you CAN’T.”

It’s ACTUALLY ERASING IT.

BUT IT'S NOT A DVD-RW

BUT IT’S A WRITE-ONCE DVD! ARRRRRRRRGH WHAAAAAAAAAAAAT!!

Be right back, gonna put my brain in the washing machine for a bit.

UPDATE 2!!

Okay, since EVERY DVD+R I was putting into the drive was making Windows AND ImgBurn say “HURRRR IT’S A DVD-RW YA WANNUH FORMAHT IT?!” I decided to put in an ACTUAL DVD-RW. Well, a DVD+RW if you wanna be pedantic. GUESS WHAT?!?!

It’s fine. 😛

No, I’m glad it didn’t come up as a DVD-R. I guarantee I would have just given up and gone to bed right then. 😛

Of course, I still have to pray that the burn actually succeeds. I think my DVD drive is busted since it has quiiiiiite a high burn failure rate recently. If it DOES fail, I’m gonna have to use my external drive. Hilariously, that is also unreliable. It likes to, y’know, RANDOMLY LOSE CONNECTION to the PC. For literally no reason. I’ll just be watching a video or something from it and BAM, BADUNK, media could not be found. Then half a second later, it reconnects. REALLY don’t want that to happen during an OS install. As a last resort, I still have the thing that helped me install Windows 10 Technical Preview in UEFI mode. My handheld video camera. Not even kidding. 😛

Anyway, time to eat while this ImgBurns. Hehehehheh shut up me.

UPDATE 3!!

Windows just showed me this:

Okay

What. I clicked on it, and Windows shows me this:

WHAT

THERE ARE NO UPDATES FFS go and die! I can’t wait to get off this broken build. 😛

UPDATE 4!!

AAAAAAAAAAAARGH NOW WORDPRESS IS AT IT!

WORDPRESS SUUUUUCKS

I can’t write a blog post in a MICROSCOPIC EDIT WINDOW!!

UPDATE 5!!

Right. It’s been about… 3 hours now. I’m STILL on Windows 10 Technical Preview Build 10074. THAT’S because the burn to the DVD+RW FAILED. No no no, actually, the VERIFY failed. Because the DVD drive fell asleep and ImgBurn couldn’t wake it up. The burn was fine; Windows picked up the contents of the disc no problem. UNTIL I REBOOTED. Then suddenly THE DISC WAS BLAAAAAAAAANK! Then, when I tried to re-burn the image, ImgBurn got stuck in an infinite loop when formatting the disc, going from 96% to 98% and then jumping back to 96%! All of this is happening while I’m TRYING to prepare Plan B by getting everything off my external hard drive, but THAT keeps friggin’ pooing itself as well, needing to take little breaks by disconnecting itself and throwing errors like:

ARSEHOLE ADAPTIVE POWER

WHAT IS WRONG WITH TECHNOLOGY TODAY?!?

UPDATE 6!!

FINALLY. The DVD is burned although the verify failed again. Adaptive Power (my external drive) has been formatted and is ready for Plan B. I’m gonna disconnect all my excess drives, and then it’s time to jump back to Windows 7 to upgrade to Windows 10.

See ya Technical Preview Build 10074! You’ve been alright. Apart from recently when you’ve been a slow-ass bag of turd. 😛

UPDATE 7!!

I am currently blogging from my phone like a spack, battling with shitting autocorrect bullshit and a cocking text editor that won’t FRIGGIN’ DO WHAT I SAY. Why? Because everything is FUCKING MAGICAL, like a unicorn SHARTING EVERYWHERE.

It took 30 minutes to get the Windows 7 installer to boot despite the fact that I’ve never ever had a problem with it before. After trying everything and eventually unplugging every USB device, it actually turns out that it can’t even launch in UEFI mode.

Then I had to install network drivers. It failed, because I needed the .NET Framework for literally NO REASON. As I downloaded that on my phone, the installation succeeded. What the fuck. I restarted like it asked me to, and guess what? Windows stops booting.

WINDOWS STOPS BOOTING.

I’d LITERALLY HAD IT INSTALLED FOR 5 MINUTES AND SOMETHING FUCKS IT UP. WOW. WHAT THE HELL.

Startup repair fixed the problem. Whatever it was. Oh, and upon booting Windows, my network drivers that seemed to not install were working. WHAT.

Validated Windows 7. Got ready to install 10. THE DISC WAS BLANK. WHATTTTTT

Seriously, it HAD THE DATA ON IT! I checked it before rebooting to install Windows 7! It’s LITERALLY IMPOSSIBLE that the data just DISAPPEARED!

So, I’be just been waiting for Windows Image Burner to burn the image back onto the disc. It’s done, and the data IS THERE. I am JUST about to boot the Windows 10 installer. HERE WE GO.

UPDATE 8!!

Can this actually get much worse?

The install completed successfully. Windows 10 was activated. Excellent. I then restarted to do a clean install. When I began the clean install, it asked for a product key. I entered my Windows 7 product key which I had just used to upgrade from Win7 to Win10. The installer said it was wrong. I checked. It wasn’t wrong.

I skipped entering the key and finished installing. Installed my network drivers. Tried to activate. Product key invalid. What the fuck. I thought they said you could do this?

Right… I’m getting fucking sick of this. I CAN’T upgrade my install from Windows 7 because I CAN’T INSTALL WINDOWS 7 IN UEFI MODE. Hello Microsoft? I have a UEFI motherboard and would like to use that functionality? The only way I can install Windows in UEFI mode is to install Windows 10 from fresh. But if I do that, hey, my key doesn’t work!

So. It’s nearly 3AM and I’m going to have to go through the WHOOOOOLE PROCESS AGAIN. Out comes the Windows 7 disc again! yaaaaaay

UPDATE 9!!

Mooooooorning. Urghhhhh. That was painful. Piece of shit OS. I have never had a Windows install go so badly before. Seriously, it kept me up until about 4:30AM. Now I’m at work, and my brain isn’t.

The stars aligned and I got it installed in UEFI mode. It turned out that you can install Windows 7 in UEFI mode. I mean, I tried that before but y’know, the installer wouldn’t launch. I fixed it by going into the BIOS, and instead of turning on “Windows 8 Support” (which deactivates Legacy drive mode), I left that off but switched the drive mode to UEFI only. The installer booted without choking. It still looked like BIOS to me, and I had to install Windows 10 before I was finally convinced that it really was running in UEFI mode. My bad, I guess? But kinda not?

Since it’s finally installed in UEFI mode after more than 6 hours of complete hell, I no longer care that it’s been installed over the top of an old OS. I’m calling it a win. All that stuff you might’ve heard about being able to do a clean install is complete bullshit. You can reset the PC to factory defaults, sure, and I guess that does count as a clean install because it apparently nukes everything. But by “clean install” I meant “install from a boot disc”, and you can’t do that if you upgraded from Win7 or Win8!

Of course, I appear to be wrapping this up as if I’m finished. The thing is, Windows 10 didn’t activate last night. It failed because of some licensing error three times before I gave up. The first time I activated Win10 before trying a clean install, it also failed in the same way once before activation succeeded, so it might be a server error.

Why don’t I just see if it activates now? Well, this is why:

Screen Shot 2015-07-30 at 11.37.07

An Internet outage in my area for the first time in about 1.5 years of living here. It’s like a huge joke. I wanted to use some of my lunchtime to TeamViewer into the PC and sort out some important stuff so that the machine was ready for me when I got home and faceplanted on the keyboard tonight, like restoring my documents from backup, installing Steam, Dropbox, Skype, Office, PlayClaw and all that. But noooooooo.

Well, I guess I’ve gotta wait. I’m pretty sure my next update will be the last one. I’ve also got a bunch more screenshots that I took during the install process in the previous update. I’d upload them but they’re on my PC at home, and heh, yep, no Internet!

UPDATE (windoze)10!!

Okay, it’s activated. Installed in UEFI mode, and activated. Thank fuck. 😛

So, what’s it like? Well… not a huge amount has changed from the Technical Preview apart from stability. All I’ve noticed is that Start menu has been tweaked and the calendar display that you see when you click the system time in the bottom right has been revamped.

They have almost ruined the Start menu for me by making one very small change. They reduced the number of columns per row of Live Tiles on the Start menu by one, and it’s absolutely senseless. Y’see, you can have a Live Tile in the following sizes: 0.5×0.5, 1×1, 2×1 and 2×2. I’m ignoring 0.5×0.5 because I don’t have enough stuff to put on the Start menu for me to use it. 😛 These dimensions mean that with a four-column Start menu, you can have a 2×2 next to a 2×1 or a 2×2 on the same row(s). With only three columns, those choices are nuked. You can only have a row consisting of three 1x1s, or one 1×1 and either one of 2×1 or 2×2. My old Start menu design:

START IS HEEAH!

I can’t do that any more. I don’t want Facebook on there, I want Calendar as a 2×1 above Weather instead, but I can’t. This is the best I can do:

My Start Menu

And it looks like dirge. 😦

I’d show you the new calendar but it’s just a calendar and I can’t be arsed to screenshot it. It’s pretty and stuff. Nothing that makes you go ERRMAAGEERDD NEED TO INSTALL WIN10 NAO

One thing that made me explode when I got it installed for the first time was THIS:

Windows Install 6

WHAT. THE FUCK. GET THAT FUCKING SHIT OFF MY MACHINE RIGHT FUCKING NOW is pretty much what I said. 😛 That, and friggin’ Twatter, and all the other cunting bloatware apps. Why MUST they bundle Sport with it? I don’t want it. If I wanted it I’d install it myself!

I’m not even going to talk about Solitaire Collection. Just go look up what they’ve done if you wanna know. 😛

One notable improvement from the Tech Preview is Quick Access. Thankfully, you can make it usable by unchecking recently used files and frequently used folders:

Yay Quick Access configuration for non-morons

This prevents Windows from clogging it up with a random jumble of files you poked recently, limiting it to stuff you’ve pinned, i.e.: stuff you actually want to see in there. You can get to that window by right-clicking the Quick Access option in the Explorer sidebar and selecting Options.

I can’t really think of anything else notable that’s changed. It feels infinitely more stable than the build I was on, so I’m actually gonna go ahead and say it: yes, you should really upgrade to Windows 10 now. It’s fine. Probably. 😛 Usability-wise, it’s… pretty much as good as Windows 7. It’s a bit better, actually, thanks to UEFI and a better Start menu.

As for the install process, the least brain-melting way of doing it is to install Windows 7/8 from fresh, then upgrade to Windows 10 from within that. You can then clean up the files left over from the upgrade process by running Disk Clean-up, then selecting “Clean up system files” when the initial scan completes. Of course, if you’re not sure whether you want to keep Windows 10, I’d hold off on doing that; it’ll make downgrading easier. 🙂

When you have Windows 10 installed for the first time, if you really want, you actually can do a fresh install from BIOS. Apparently. Someone I know did so by pulling out his Windows 10 key using Magical Jelly Bean Keyfinder, then reinstalling Windows 10 from BIOS and entering this key during setup. Instead of going through the process of installing Magical Jelly Bean Keyfinder, though, you can do it way quicker with this VB script. Download and open it, and boosh, your product key is displayed in a dialogue box. 🙂 This method seemed to work for my friend, but I haven’t verified it myself.

Right, I think that’s it. If anyone has any questions about Windows 10 or the install process or anything that I probably missed, feel free to drop a comment. 🙂 For now, though, I’m gonna drop myself on my BED. I’ll leave you with the most awesomest thing I’ve seen in the past month:

TA TA

Advertisements